If you get .NET errors that reference

 

<system.web>
<httpRuntime requestValidationMode="2.0" />
<!-- everything else -->
</system.web>

 

It means that the application you are trying to run has set the property requestValidationMode to function the way it acted under .NET 2.0, but this directive only makes any sense under .NET 4.0 or greater, and your website is not set up to use .NET 4.

You need to run the application in a separate application pool and set it to run under .NET 4.0 (which, of course, needs to be installed before it can be used).

To fix it:

  • Create a dedicated application pool for the site.
  • Assign Application process identity as “Network Services”.
  • Set .Net Framwework version to: V4.0
  • Set managed Pipeline Mode to: Integrated
  • Now assign Modify permissions on IUSER and Network services on Httpdocs folder and all child domains.
Resources