After doing a series of updates to a Drupal installation, the following error appeared on all admin pages and edit pages:

“call_user_func_array() expects parameter 1 to be a valid callback, function ‘clients_access_callback “

Other symptoms included that the database could not be updated to complete some of the following updates, and search no longer worked.

To resolve this error, truncate the cache table in the database. You may also need to disable the theme then enable it again.

This problem may be caused by removing modules or themes from the modules folder before disabling them in the modules or themes GUI.