When attempting to launch browser-based SCORM courseware, people have been getting the error: “Several Java Virtual Machines running in the same process caused an error”

Apparently many people have this issue since upgrading java. I came across it because it can affect the delivery of elearning courses if the learning management system relies on a java-applet based scorm adaptor to communicate.
This is caused by a change in the way the java plugin operates, and has supposedly been fixed by a new release:

Java SE 6 Update N Early Access

Java SE 6 Update N Early Access > New Java Plug-In
Release Notes for the Next-Generation Java* Plug-In Technology
The new plug-in immediately fixes several longstanding bugs, among them the following:

  • 6359309Large setting for -Xmx param prevents plugin from starting in Internet Explorer
  • 6433218Java applet fails with Large Java Runtime Parameter setting
  • 6504236Implement IE Broker process for File I/O on Vista
  • 6516270Java applet failure with IE7 displaying “Several Java Virtual Machines running” error

    etc., etc.

More information on the specific bug 6516270 is available here